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* Projects and Directories

* Help with GAMS and GAMS Studio
 Search and Replace

* Opening and Using GDX Files
 Reference Files

* Other Tools

— Pin view
— Folding
— Navigating
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Projects and Directories
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& Projects and Directories 1

« Storing files in appropriate directories is
critical - GAMS needs to know where input
files are located and where output files are
stored

* GAMS Studio organises the files in
PROJECTS using project files (**.gsp)

— Project files can be ‘explicit’ or ‘implicit’
— Project files can be created automatically or
manually

* Projects and Directories
— One Project per Directory

More GAMS & Studio, 2025 © cgemod 4
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Projects and Directories 2

e GAMS Studic - No active process

mu GAMS Studio - No active process File Edit GAMS MIRO Tooks Wiew
File Edt GAMS MRO Tools View Help =0 ¢>ame g RemOVG fI'Ol’Il
K@ ¢ ame k- ot LA .
N ar— e Project — closes
e L rT——— files but does not
& bid.gms & =3 8 Open Terminal
b » o delete a stored file

Collapse Al Projects

e
. ;nene B Epnaan
» o * proc|
[E] Add New Solver Option File -
henemrl Add New GAMS Parameter File j "
“* pr - Ll
Clean d
- Focus Praject
Select All z v s sa|
re s Bemovefrom Project

Collapse All Projects

Delate File
e

Expand All
gml’;mﬁd " Delete Flle -
QOpen Project... bn

Move Project Fle

: ) deletes a stored
: Remove Project file

from Project

Explorer — does

not delete any %
stored files

© cgemod 5

Copy Project.

GAMS & GAMS Studio, 2025

Projects and Directories

ad GAMS Studio - No active process Local Disk (C.

cgemod gamstest

Many projects can

File Edit GAMS MIRO Tools Vie

E=0 ¢ Qin e . .
N = "be included in a
: oo single directory!!

D warer " Opening projects

v %2 chenery

eneryaen i File>Open..
a0 thenery.gms PR ;
- e s Choose any **gms or **.gsp

v %2 procsel
procsel.gde
4 procsel.gms
procseList
[ procselref
~ w scarimcp
= sarfmep.gdx
gk scarfmep.gms
[3) scarfmep.ist
scarfmep.ref
v %2 tmsport
tmsport.gdx
b tmspart.gms
tmsportIst

tmsport.ret
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Opens all related files

3 Projects and
groups of related
files linked by gsp

files
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Project Options

B GAMS Studio - No active process
File Edit GAMS MIRO
E=0 aQma Je-

Project Explorer

cols View Help

ms 1 bidgms b progselgms b scarfmep.gms % tmsport] B |4
~Show All- ~

2

Project file C\cgemod\gamstest\trnsport.gsp

Name trnsport trnsport

Working directory | C\cgemod\gamstest =
Base directory |C:\cgemod\gamstest

Main file C\cgemod\gamstest\tmsport.gms -

Dynamic main file

Parameter file -none- -

Active Project: project name in BOLD

Main File: file with GREEN arrowhead U,

GAMS & GAMS Studio, 2025 © cgemod 7

New Project 1

* in Windows Explorer create a directory for the e
new project, C:\cgemod\test, Bed €5 ame

[emp—

3
<
H
]
o
[

option ‘Open file in current project by default’ w fud .
is selected, N

* choose File>New Project,
* the default name for the project is newProject,
* rename the project name as test in the editor

window
* set the Working directory to C:\cgemod\test,

using the BROWSE button, Jeomt
* Base and Working directories have same name, B2 TEPC > LoclOBK(CH > cgemed > et
¢ choose File>Save — DO NOT USE SAVE AS ~ oomer ' —
« choose File>New that will open a Windows o

Explorer window with default File name of R
new*** gms, Fierame [EEED

* click SAVE and new**.gms will appear in the T ———
‘test’ project. N

Energy coding

GAMS & GAMS Studio, 2025 © cgemod 8
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New Project 2

Set ‘Save as type’ to *.gms

Bu Create new file... X

P < v < cgemod » test v O Search test [

[ Organise > Newfolder =- @
> cgemod cours Name Date modified Typef
> cgemod devel I No items match your search. E
> DATA E

> B Desktan E

File name: | newl.gms =

Save as type: | GAMS source (*.gms)

GAMS project (*.gsp)
~ HideFolders | GAMS Include files (*.inc) |
Option files (*.opt ".op” ".c%)

GAMS Configuration file (gamsconfig.yaml)

GAMS Connect VAML file (* yaml)

Parameter file (*pf)

Text files (*.0)

External files (".efi) )
Al files (")
GAMS & GAMS Studio, 2025 © cgemod 9
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GAMS Studio

Motivation

Central Widgets

Wnicome Page

Help with GAMS and GAMS Studio

Select: Help > GAMS Documentation,or F1,

orView > Help

: \
€ErE0%0CL®E -
More GAMS & Studio, 2025 © cgemod u
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Help wit MS Studio: Short Cuts
°
. L . . :
2. Advanced Text Manipulation
Action Shortcut macOS Description
Remove Line Shift - Del Removes the current line
Duplicate Line | Ctrl- D Command - D Duplicates the current ling
Lowercase Alt - Shift - L | Option - Shift - L Toggle selection to lower case
Uppercase Alt - Shift - U | Option - Shift - U Toggle selection to upper case
Tab Tab Tab Add spaces till next tab size
Untab Shift - Tab Shift - Tab Remove spaces till previous tab size
Indent Ctrl-1 Command - | Indent complete line
Outdent Gtrl - Shift -1 | Gommand - Shift- | | Outdent complete line
Find Ctrl-F Command - F ‘Open Search & Replace window, filling search field with selected text if there is any.
Find Next F3 F3 Jump to next search result if
Find Previous | Shift - F3 Shift - F3 Jump to previous search result
3. Navigation & Selection
] Action Shortcut mac0S Description
Zoom In Gtrl - +or Gommand - +or Zoomin
Ctrl-=or Command - = or
Ctrl - Wheel Up Command - Wheel Up
Zoom Out Ctrl - - or Command - - or Zoom out
Ctrl - Wheel Down Command - Wheel Down
Reset Zoom ctrl-0 Command - 0 Reset zoom A\
Match Parentheses Ctrl-B Command - B Jump to matching parenthesis
More GAMS & Studio, 2025 © cgemod 12

12




Introduction to GAMS and GAMS Studio GAMS & GAMS Studio, 2025
© cgemod

@
Help with GAMS Studio: Settings

gzen e
» Fume Suso apes

GAMS & GAMS Studio, 2025 © cgemod 13

13

(o)

Search & Replace
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Search and Replace
Parameter c(i,j) 'transport in thousands of dollars per case';
c(i,j) = £*d(i,j)/1000;
variable . mm Search & Replace K
%x(1i,J) '"shipment gu
z "total transl Search Term: |cust v| Clear
Replace: | | Replace
Positive Variable x; [] case sensitivity [ ] Use Regex  [»] Whole Words Replace Al
Equation ThisFle < Find Al
'define a | |
. 4 matches.
supply (1) 'observe
demand (j) 'satisfy demand at market j':
C z =e= sum((i,3), c(i,i)*=x(i,3)):
supplv (i) .. sum(i, =x(i,7)) =1= a(i):
Y
More GAMS & Studio, 2025 © cgemod 15
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= ProcessLog
~ Filename
rs/scott/D ts/GAMS/Studi am
au Search & Replace X
rs/5Cott/D t5/GAM am
_ | search Term: ‘mst v‘ Clear /D ts/GAMS Sty
/D ts/GAMS/St
Replace: | || Replace e o .
Case Sensitivity [ ] UseRegex  [] Whole Words Replace Al L Documer e rtlst
T D p
i cn Docume Ansportist
Include Fiter: | ~] an Documer Armsportlst
A D s /GAM: e
Exclude Fiter: [ <] Hney (3
[l Docume /i st
s | 20 matches; 4 files searched. ‘ cn Documer Atnsportlst
L Documents/GAMS, Amnsportlst
L Documed Amsportlst
(=71 ‘Documel /i rt.lst
£
- L Documer Amsportlst
A Documed Arnsportlst
i Docume /i rtlst
cn Documer Amsportist
More GAMS & Studio, 2025 © cgemod

Line

a
a2
a7
52
56
7
)
a9
54
58
7
79
106
12
118
124
128
189
191

This problem finds a least
Parameter ¢} ‘transport
.‘total transportation co:
cost “define objective T
eost. 7 =e=sumi(ij), <
..This problem finds a lea
..Parameter c{i ) ‘transpor
.‘total transportation co:
52 cost
56 cost..

“define objec
z=e= sum(fij
- cost =E= define obje
<ost.. - 0.225%(seattle,ne’
0225 cost

0153 cost

-0.162 tost

.2 total transportatio
1 cost

- EQU cost

<ost define abjective fun
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GDX Files

Y
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g v “ume m-
frolect Bplom Weicome  unspot.gms = unsportgax B =
Show All- -
. | Export ||Table View || At Pre.ces | Reset
- Entry  Name =~ e Dim Records Test
% tmsport.gms
) tmeportist 3a Parameter 1 2 capacity of plant i in cases e T e ks
9 tmsportret 4b Parameter 1 3 demand at market j in cases seottle  |new-york 0225
10 cost  Equation (.. 0 1 define objective function sattie  |topeka 0162
5d Parameter 2 6 distance in thousands of miles P pe—— 0225
12 demand Equation (... 1 3 satisfy demand at market j sai-diego |chicego 0162
6f Parameter 0 1 freight in dollars per case per thousand miles san-diego topeka 0126
1i Set 1 2 canning plants
2 Set 1 3 markets
11 supply  Equation (... 1 2 observe supply limit at plant i
8 x Variable (P. 2 6 shipment quantities in cases
9z Variable Fr... 0 1 total transportation costs in thousands of dollars
Y
More GAMS & Studio, 2025 © cgemod 18

18




Introduction to GAMS and GAMS Studio GAMS & GAMS Studio, 2025
© cgemod

H
"
i
%
B
L]

W Eport | ListView Pre.ces || Reset
iy tame * e om  Recorss et

3a Parameter 2 capacity of plant i in cases

ni' [j* [xvabe
40 Parameter 3 demand at market | in cases

1
1
u new-york  cicago topeka
7le Parameter 2 6/transport cost in thousands of dollars per case -
. seattie 0225 0153 0162

10 cost Equation ( 0 1 define objective function oo P
sd Parameter 2 6 distance in thousands of miles
12 demand Equation (. 1 3 satisfy demand at market |
61 Parameter 0 1 freight in dollars per case per thousand miles
10 Set 1 2 canning plants
2) Set 1 3 markets
11 supply  Equation (. 1 2 observe supply limit at plant |
8x Variable (P 2 6 shipment quantties n cases
92 Variable (Fr. 0 1 total transportation costs in thousands of dollars
Export List View Attributes Preferences _ Reset
Search ... WS < | > Squeeze Defaults
w®i | xj? | w Value v/ Squeeze Trailing Zeroes
- new-york |chicago topeka Formet: Aot
P |8 &
seattle 225¢-01 1.53e-.. 1.62e.. —oo" U
san-diego | 2.25e-01 1.62e-.. 1.26e.. Yy
More GAMS & Studio, 2025 © cgemod 19
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Filtering in GDX View

I | % vane
7 [ter M|
new-york
chicago
topeka
Select Al Invert Deselect All
[ Hide unselected items
)
= Min: Max: =
0.126 | [0.225 |
2t
a2t [ Exclude

Show Special Values:
EPS +INF -INF
MNA UNDF Acronyms

Reset Apriy J
N~

N

More GAMS & Studio, 2025 © cgemod 20
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Filtering in GDX View: n-dimensions
°
= belp
b -
o wekome ¥ tmspargm: tmapon ga & chenery gms = thenerga O
te S| Export || List View
Enty - Mame e Dm  Recorss et =| searc S8
1l Set ! 4lsectors ximh'  x*?  nsde® |wit |wvaive
2t Set 1 3 tradables
light-ind food+agr heavy-ind services
3 imh Set 1 3 possible elasticities
F = 5 low a distr 0815 0344 26 08
1 other parameters
= = effic 383 324 2 18
Al 1 Al
5 ias 0 Aliased with i b distr 0276 1034 26 o7
6 Parameter 2 6 input coefiicents
= = =t effic | 2551 339 4
7|pa: Parame 4 production data
. = ~ = medium a subst on 029 02 005
— e = distr 0326 0443 0991 000798
1
91tdat  Parameter 3 8 trade parameters — 207 13 P p—r
10 mew  Parameter 1 3 intercept on i cost funci
= e = bswst| 02 058 Y]
1 xsi Parameter 1 3 slope of import cost function
= = = distr 041 047 022 008
1 1 function
gam rameter intercept on export revenue o 19 13 13 180
13 alp Parameter 1 3 slope of export revenue function high|a|suber 045 115 04 02
14ynot  Parameter 1 4 demands in base year
— ! = distr 0456 0483 0917 023
15 sig Parameter 1 4 elasticity of substitution capital to labor
= = effic 4 333 18 182
1 meter 1 4 price elasticity of demand
— - “ b subst 093 115 08 04
17 tho Farameter 1 4 substitution parameter in production funtions
- distr 0484 0.483 0769 0344
18 del Parameter 1 4 distribution parameter in production functions
effic 4 333 1240| “ 296
19 ety Parameter 1 4 efficiency parameter in production functions
30 har  Dacameter n 1 et cnehs of Lo =~
. LS
GAMS & GAMS Studio, 2025 © cgemod 21
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| ] bl ] GDX '
Weicome 5 trmaport gm mipent gon i chenenygm B cnenenoes 0
» | Export
Eny v om o 8
X 4 » ' * Level
5 Variable (7. 1 4 value added per unit output at current prices Hight-ind 11288
%y Variable (9. 1 4 final consumption S 35893
27p Variable (P. 1 4 prices hesvy-ind 182798
281 Variable (P ' 4 labor use per unit of output T P
29k Variase (7. 1 4 capital use per unit of output
B8 GAMS Studio - No active process
File Edit GAMS MAO Tooks View Help
=03 € ame k-0
sptorer 5 =
e Enia s Wekome B neport.gng = tmsport.gax )
~Shaw Al
o — o | [Fiter TS| Eport | Listview || Attbutes, | Pre.ces || Resel
= tmsportgdx Enty  hame - Hoe Dim | Recorss Tt seare vl Lewel
R unsport.gms 3a Farameter 1 2 capacity of plant i in cases Tl Clm ™
[3) tmportist ib Parsmeter 1 3 demand ot market | in cares "
= d - eka
B truportet i Farame 2 s tansport cost mthousands ot outars per case Lower Bound
10 cost Equation [zez) 0 1 define objective function L | Upper Bound
HE) Farameter 2 6 GIStance In thousands of miles e Seale o
12 demand  Equation [=g=) 1 3 satisfy demand at market j ] o
61 Farameter o 1 freight in dollars per case per thousand miles. jrmvet Seteclion,
1 set 1 2 canning plants
2 set i 3 maskets
11 suppy  Equation f=1=) 1 2 observe suppy Iimit 3t piant
8z Variable [Free) o 1 total transportation costs in thousands of dallars
More GAMS & Studio, 2025 © cgemod 22
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% Format in GDX View

Process Log

anfig.yaml ma smod =
Info [16:58:28]: Started: C:\GAMS\studio‘\studioc.exe
tes Preferences Reset Info [16:58:29]: GBMS license found at C:

- \Users\Jchn\DccumentshGAMS\gamslice.TxtT
Squeeze Defaults

V| Squeeze Trailing Zeroes

Format: g-format =

Precision: ]
- | Display format for numerical values:

g-format: The display format is chosen automatically: f-format for numbers closer
to one and e-format otherwise, The value in the Precision spin box specifies the
number of significant digits. When precision is set to Full, the number of digits used
is the least possible such that the displayed value would convert back te the value
stored in GDX. Trailing zeros do not exist when precision=Full,

fformat: Values are displayed in fixed format as long as appropriate. Large numbers
are still displayed in scientific format. The value in the Precision spin box specifies
the number of decimals,

e-format: Values are displayed in scientific format. The value in the Precision spin
box specifies the number of significant digits, When precision is set to Full, the
number of digits used is the least possible such that the displayed value would
convert back to the value stored in GDX. Trailing zeros do not exist when
precision=Full,

GAMS & GAMS Studio, 2025 © cgemod
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oo
Format Preferences for GDX View

Ba Settings X
1

General | EditorBLlog | GDXViewer | Colors  Remote  Misc. | Update
Default Settings

Symbol View: | List View  +

Attributes Preferences
V) Level Squeeze Defaults
V| Marginal V| Squeeze Tiailing Zeroes
V| Lower Bound Format: g-format -
V| Upper Bound Precision: n -
V| Scale
Decimal Separator in Copied Data
® UseStudio default:
Follow system language:
Use custom character:
GAMS & GAMS Studio, 2025 © cgemod
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MO0} List View
|‘-)<i‘ |'-}<j1 |‘-)<Leve|
new-york  chicago  topeka
=5
s Copy {comma-separated) Ctrl+C
seattle Copy (tab-separated) Cirl+5hift+C
\il san-diego -m Copy Without Labels (comma-separated)
j Copy Without Labels (tab-separated)
p... )
Auto Resize Columns Cirl4R
Select Al Ctrl+a
nti
i...
Y
More GAMS & Studio, 2025 © cgemod 25
Exporting from GDX Vi
tmsport gox [
20| Bport Table View
Text Search ... Wi
capacity of plant i n cases
: 2 GDX Export X
! TargetFormat: | Excel ~
| Excel File: Cicgemodtest2\tmsport_exportads
| connect e C\cgemoditest2\trnsport_exportyaml Browse.
| Apply Filters v
| Hidden Attributes
; EPS: EPS INF: |INF -INF: |-INF UNDEF: UNDEF NA: NA
Export Entry  Name =~ Type Dim Records Text
3a Parameter 1 2| capacity of plant in cases
4b Parameter 1 3 demand at market | in cases
T Parameter 2 6 transport cost in thousands of dollars per case
10 cost Equation (=e=) 0 1 define objective function
5d Parameter 2 6 distance in thousands of miles
12 demand  Equation (=g=) 1 3 satisfy demand at market j
6 f Parameter 0 1 freight in dollars per case per thousand miles
1 Set 1 2 canning plants
2jj Set 1 3 markets
11 supply Equation (=I=) 1 2 observe supply limit at plant i
8x Variable (Positive) 2 6 shipment quantities in cases
9z Variable (Free) 0 1 total transportation costs in thousands of dollars
N
Select All Deselect All Export |~ Cancel
GAMS & GAMS Studio, 2025 © cgemod 26
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Reference Files

RN
More GAMS & Studio, 2025 © cgemod 27
Ref Fil
File Edit GAMS MIRO Tools View Help
=0 ¢ Q& b=~
Project Explorer 54 P Run =]
- B Fnsport.gdx [
Show All- = | 4 ¢f> Compile Shift+F9
Problem (TRNS.
~ %@ tmsport W% Run with Debugger F11 ¢
= rt.gd N
meportgax Dse Step start with Debugger Shift+F11
ap: trsport.gms
[3) trmsportist V| 1Create GDX  PE
trnsport.ref 4 Compile with ... Shift+F10 | || 2 Create RF
@ Rrunneos 3 Profiling
4 Run GAMS Engine In
=
icome & umiper gm Bompotret @ E umporgan
All Symbols (13} m €
Location Line Cotumn
Set (2 Entry Name - Type Dim Domamn Text O Dt
Acromym @ 138 Set 10 canning plants tmspartgms an
“ (0) Defined
Varible @ 199 et 10 o = A
Fometer 65 140 a Parameter 1 capacity of plant i in cases msportgms an
1481 b Parameter 10 demand a1 market | in cases (0) Implicitly Assigned
Equation G) 24d Parameter 2 G distance in thousands of miles (0) Controlied
(0) Indexed
Model (1) 143t Parameter 0 freight in dollars per case per thousand miles ~ (1) Referenced in
File (0) trmsportgms 5631
Macro (0) 145 x Variable 20p shipment quantities in cases.
1462 Vaniable 0 total transportation costs in thousands of dolars
Function (0)
147 cost Equation 0 define objective function
Unused (0)
148 supply  Equation 1 observe supply limit at plant I
File Used () 149 demand  Equation 10 satisfy demand at market §
150 transport Mode 0
More GAMS & Studio, 2025 © cgemod 28
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Reference Files

Welcome glb_CC_5.gms gb_CC_5lst gb_cc_sref | gamsconfig.yami
ulsymbols (358) |Fiters|  |[]AlColumns
Set (172) Entry  Name Dim Domain Text Location Line Co
Acronym (0) 147 a 1 (saq) activity accounts ¥ (1) Declared in
variable (142) 182 a_h 1 (sac) Activities and households glb_CC 5.gms 2383
Parameter (418) 156 a_k f 1@ Activities with fixel capital (1) Definedin )
Equation (115) 155 aagg 1 (aagg) A e s o IPE et bad in- RSN
(0) Assigned
Model (1) 148 aagr 1 (@) Agricultural activities (0} Implicitly Assigned
File (10) 152 acns 1@ Construction activities (548) Controlled in
Function (1) 225 acx 2 (ar) activities purchased domestically (1610) Referenced in
Unused (59) 226 acxn 2 (an activities NOT purchased domestically
File Used (10) 150 afd 1@ Food activities
151 aind 1 (@ Industrial activities
193 aleon 1@ activities with Leontief top level prodn function
149 anat 1 (@ Natural resource activities
241 ap 1 Aliased with a
191 agx 2 (an Activities and regions with CES fn at Level 1
192 aqun 2 (ar Activities and regions with Leontief n at Level 1
154 aser 1@ Service activities
153 auti 1 (&) Utility activities
144 cagg 1 (cagg) Set of commadity groups for reports
\
More GAMS & Studio, 2025 © cgemod 29
29
Other Tools
\
More GAMS & Studio, 2025 © cgemod 30
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PIN View

“Studio provides a Pin View to carry a clone of a selected tab. This

allows user to have two file contents visible at the same time”
GAMS Studio documentation

¢ Uses include viewing
— programme file (*.gms) & reference file (*.ref)
— programme file (*.gms) & related file
— alternative files, e.g., 2 INCLUDE files

Using PIN View
1. Select the file to PIN
2. Menu: View>PIN Right or PIN Below
3. Select the file to be viewing in the ‘main’ window **

More GAMS & Studio, 2025 © cgemod 31
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PIN View (Right)

programme file (trans.gms) & reference file (trans.ref)

SOLVE TRANS

DISPLAY X.1, X.M :

Using the reference file to find symbol in the programme file
In the reference file
1. Select the symbol type in the left panel for the *.ref file
2. Select the symbol in the middle panel for the *.ref file AN
3. Select the attribute for the symbol in the right panel for the *.ref file

More GAMS & Studio, 2025 © cgemod 32
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SOLVE

DISPLAY

GAMS & GAMS Studio, 2025
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GAMS & GAMS Studio, 2025

Pin View (Right) — Large Model

wezon £ g tamom ] sotsomesbrc @ wgt ot = mrone
| smess 0 W
ac(c) Armington w()  [ewy  tune e -
delta(c P sat Actoses
snaeta) Vatle (37 | 156 magp set Agregat actey g
Paanete (69 | 10wy sat Al Achites
Eamtn (0 | 24w sat ' -
: M () 15 e Frcn 0 0 n
Fie ) satémow 102
# | Ancen
Urnnd (57)
Fle sed ()
20 et Achies wih ET frch
QMO (c) = (SAM("x + SAM("imptax",c))/PMO 0 scen set Aches wihout CET &
194 00 ot Coreructon Actoes
QDO (c) + ; 229 srp set Wores it s
P — Oarmes: acaty vt
07 ACTOUTTGC  Equaten FOC for domest scave
) 28 ot Faame s net forfc
= (SAM("row",c) /ERO) /QMO (c) ; 636 AP0 ywede 2 (fa) St pwramerer fr focc
7 aoroo Pawme.  2(fa)  Shtpwamets forfack
06 acyes set f setfor st et
0 som Vwaie ) shfpwrameter for CES
™ a0 Farame o ot parameterfor CES
36 a0a0t  paame ) Lo for feumg ot v
AND cm(c)) - igma") a1 omD)  vwse 0 Scaing Facte for st
71 A0W00  Paame. 0 Scawg Factrfor St
34 a0 parame S pwameter for CES
o 1)) 6 ADUCEE Equten o pwameter fr CES
&1 A - M paamete or CES.
clc)+1) + PD( %7 a0 Fwame P——
% saett Puame 21 for ey of v
ac(c)$(cd(c) AND cm(c)) 64 A0UD) e 0 Scaing Factr for ¥R
180% = 000|(c) / (delta (c) *QMO (c) ** (~rhoc (c) ) % A000D  Pesme. 0 Scaing Factr for ¥Ry
+(l-delta(c))*OD0(e) ** (~rh TS, ] w ot parameter for CES

© cgemod 34
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Folding Text

GAMS & GAMS Studio, 2025 © cgemod 35
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Navigating Files

\
GAMS & GAMS Studio, 2025 © cgemod 37
A ing Fil
File Edit GAMS MRO Tooks View Help
= Qe b~
Project Expl 5 X
roject Explorer [ eIoame B stgtgms @ | %0 o ¥ stg t data_load.inc
-Show All- e
T %t stot o ;
- 1.1_Model_dat: . : :
1Mo ::T ’ Sofftext C + .
ata_load.inc t l l k
ST Cnume 1 1 sedel dsesss ri+Clic
SINCLUDE 1_1 Model datal\stg t data load.inc
EEdO v wms e
Project Explorer T e i atg toms 5 stg.cpamaatbinc B | o]s [ =] Froceston
Show All- = —--- GDXin=C:\cgemod\stg t\1_1 Model «
« o lstot . --- GDX File (SgdxIn) C:\cgemod\stg -
~ = 11_Model data stg_t_data load.inc(545) 3 Mb
stg_t ms 3 3 Mb
au sto.tdata_loadinc GDPO GDP from Expenditur - N
© = 2indude -—- iagnost.inc(558) 3 Mb
- RBSORPO Absorption -,
4 sto_t pamaaiib.inc £ ms (529) 3 Mb
sto.t gdx L. stg_t_parmcalib.inc(S06) 3 Mb
b sto_t.gms --- N\cgemod\stg thl 1 Medel
--- GDX Fil SgdxT, g d\ st
3 sta et WALRASO slack variable for 4le (3qdxIn) P—
stg_t.ref . Stg_t_parmcali
sto_t data_load.gdx i -
[E) sto_t data_loadist ‘ ==
\
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