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[ ] L]
tudio Settings: Workspace
[ ]
B Settings x [
General Editor & Log GDX Viewer Colors Remote Misc. Update ‘Workspace
Default Workspace
C:/cgemod/gamstest Browse
Clean-up Workspace
Filter Descriptien =
*bak Remove all backup files.
bk Remove all autosave backup files.
*.g00 Remove all GAMS work files.
".gdx Remove all GDX files.
*log™ Remove all LOG files.
*lst Remove all LST files.
i Remove all LX files.
*.ref Remove all REF files.
*.~tmp”  Remove all temporary text files.
225 Remove all scratch directories.
~".ams Remnve unsaved crash recovery files. -
Add Delete Select All Deselect All
Workspace =
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ommand line and GAMS Configuration
Command line
ols  View Help

"5 - A | rf=default cerr =5 gdx=default s=zave|

Welcome trnspart.gms El trnsport.ref trr

1r

GAMS Default Configuration

Welcome trmsport.gms gamsconfig.yaml B tmsport.ref tmsport.gdx chenery.gms chenery Jst chenery.qdx trsport st
Filter Parameters ..
Key Value minVersion maxVersion Parameter Synenym Defvalue Range Type Description
Action A CE R, G, E..,GT} Enumstr GAMS proce
W Reference Default AppendExpand A 1 0,1 Erumlnt Expand fle
W cer 10 AppendLog AL 0 o1 Enumint Log file app
AppendOut A0 0 {01 EnumInt Output file
AsyncSolLst 0 0,1+ EnumInt Print solutio
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B Libraries and User Model Libraries

User Model Libraries are libraries additional to those
provided by GAMS

* In Windows Explorer create a directory, C: \cgemod\libraries.
We suggest doing this on the top level of you working drive (C drive).

¢ Add the sub directory trans 1ib to the master directory, i.e.,
C:\cgemod\libraries\trans 1ib. (Each course addsa
library).

* Add the sub directory downloads to the master directory, i.e.,
C:\cgemod\libraries\downloads. (This sub directory is to
keep the downloads in case a library is corrupted.)

* Download the trans.zip file from the cgemod site
(http://cgemod.org.uk/int gams.html) (save in the
download sub directory).

* Unzip the contents of the file trans.zip into the sub directory
called trans 1lib.
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ibraries and User Model Libraries v1
Making the User Library available in Model Library Explorer
[ —— "« Open Studio settings - File >
e Settings or F7 and go tothe
m— e Misc tab.
v — « Change the path for the User Model
e library,
m——— . C:/Users/../Documents/GAMS/
D e o f oo onen modellibs (the exact path will
depend on the settings on your PC) to
_ C:/cgemod training/cgemod
lib.

* Close down the Studio Settings
window remembering to click OK at
the bottom of the M1 sc tab.
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ibraries and User Model Libraries v2
Making the User Library available in Model Library Explorer

* Copy all of the files in the cgemod 1ib sub
directory — just the contents of the directory NOT
the directory.

& seng * Open Studio settings - File > Settings
Grwd b @ G e or F7 on the toolbar and go to the Misc tab.
AT * Click on the ‘Open Location’button (—),

which will open a Windows Explorer window.
LS Make sure the directory ...\GAMS\modellibs

is open.

* Create a sub directory called
..\GAMS\modellibs\cgemod 1lib

* Then Paste the contents of the
C:\cgemod training\cgemod 1ib
directory into the
..\GAMS\modellibs\cgemod 1lib
directory.

* Close down the Studio Settings window
remembering to click OK on the Misc tab.
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Libraries and User Model Libraries

A

mn Model Library Explorer

Filter model tabs ...

; Intro to Studio Lib (5)  Model Library (430) ~ TestLibrary (895)  APILibrary (51)  Data Utiities Library (145) B

=
|

| | SegNr - Name Model Type Type Modeling Points
._; m transpart] Transport cost problem LP Structure of GAMS model  MNone
| oz Syntax Syntax errors 1to 4 LP Debugging a GAMS model MNone
03 Execution Execution errors 1and 2 LP Debugging a GAMS model Mone
M transport2 Transport model exercises  LP Madifying a GAMS medel  Adding markets and wholesalers
05 transport3 Transport exercise solutions LP Madifying a GAMS model  Adding markets and wholesalers
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Libraries and User Model Libraries

9 > cgemod_training >

A Name Date modified Type Size
cgemed_lib 1:32 File folder
downloads 31 File folder
View > . o .
> Using File>New Project
Group by
.
L — to create a new directory
Customise this folder.
.
AND a new project
Paste shorteut
Undo Delete Ctri+Z
Give access to >
& SVN Checkout...
2 TortoiseSYN >
&] WinMerge
New > Folder
Properties &) Shortcut

[ Microsoft Access Database

| » cgemod_training »

~ Mame Date medified Type
cgemed_lib 0 2022 11:32 File folder
downloads 22 11:31 File folder
transport )22 11:58 File folder
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File Edit GAMS MIRO Tools View Help
=0 €-> & -l
Project Explorer 8 X | \elome [ [transport] B
#¢ transport
MName |h'anspnrt
Working directory |C:\GAMwaammg\transport
Base directory |C:\GAMS_wammg\transport Warking director
]
Main GM3 -no runnable-
File Edt GAMS Took View Help
E&EQ € ol =- 0~
Progect Exglorer # x| wecome Iranscort
Spimapes rame warapart
Working drectary [C:\GAMS_vranng trarsort
Base drectory [C1GAME_raningitrerepeort
e
4 Mode Library Explorer X
T =]
& oo Sucdolb (5)  Modellbrary (4X)  Testibrary(S35)  APILbrary (81)  DatsUtitesibrary (146)  EPLbrary(104)  FiNibrary(5)  NOALbrary (4 P
Seqhir  Name Model Type Wpe  Modeling Pains Experiment
0 tansport! Transpert costproblem L0 Structure of GAMS madel Mone
@ Sntm SytmemorsTtod 1P Debugging  GAMS madel None
03 Eecution Erecubonerorsland2 L9 Debugging s GAMS model None
04 wanspon2 Tansportmodel exercises P Modifying a GAMS model  Adding markets and wholesalers
05 tanspon Tansport exercise solutions 1P Modifying s GAMS model  Adding markets and wholesslers
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Libraries and User Model Libraries

4 GAMS Studio
File Edit GAMS MRO Tools View Help

=0 € 2N k- 0]

Project Explorer B X weleome [ [transport] [ trans.gms (B
¥ % transport 1 BTITLE A TRANSPORTATION PROBLEM (TRNSPORT,SEQ=1)

ap: trans.gms 2 SOFFUPPER

cgemod_training * transport

~ MName Date modified Type
D clean_tr.dat 03/09/2022 12:07 DAT File
A trans.gms 12:07 GAMS file
D trans.gms.1.bak 12:04 BAK File
@transexcel.xls 12:07 Microsoft Excel
@tutorial.pdf 12:07 Microsoft Edge P...
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<y Comparing Files
Access to comparison software is valuable. They allow easy
comparisons between different model versions, which can be
helpful when searching for ‘changes’, ‘errors’ and ‘bugs’.
1. MS Word: using Review>Compare produces a comparison
of two selected documents
2. WinMerge: using File>Open then selecting 2 or 3
documents to compare
3. NotePad++: open two documents and then using
Plugins>Compare
The courses offered by cgemod assume the participant has access
to comparison software. Our examples assume WinMerge.

With open-source programmes be careful when installing
them, especially if they come from third-party sites.
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Studio with Modular Projects
MName - Status Date modified Type Size
10_C5_Data [~ 18 File folder
11_DYN_Data ®=a File folder
20_GDX_Data [} File folder
21_Restart [ ] File folder
30_C5_Calib [~ =3 File folder
31_C5_Close [~ 1=3 File folder
32_CS_Expts [~ ]S File folder
A0_DYMN_Calib [~ 18 File folder
41_DYMN_Close (-3 File folder
42_DYN_Updates [} File folder
43_DYN_Expts [ ] File folder
50_CS_Analysis [~ 3] File folder
51_DVN_Analysis [~ 1=3 File folder
60_Results [~ =3 File folder
= clean_stg_t.bat [~ 18 Windows Batch File
B stg_tgms (-3 GAMS file
au stg_t_dyn.gms [} GAMS file
B stg_t_dyn_expt.gms [ ] GAMS file
STAGE t model with comparative static and recursive dynamic modules
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Studio with Modular Projects

File Edit GAMS MIRO Tools View Help

E=0 ¢ e k=- 0
Project Explarer B X | welcome ) stg_tdyngms B sto_t dyndst D) sto t dynref [0
~ e¢ stg t dyn g

= stg_t_dyn.gdx
mb: stg_t dyn.gms
B stg_t_dynst

stg_t_dyn.ref

ae GAMS Studio
File Edit GAMS MIRO Tools View Help

=0 ¢ & =~ H-

Project Explorer 8 X | welcome [[]  stg_t.dyngms ]  stg_t dataloadinc @ stg_te
W e stg t dyn 1
v 30_C5_Calib 2w Sontext

mw sto_t_data_load.inc
stg_t_dyn.gdx E
stg_t_dyn.gms

stg_t_dyn.Ist

stg_t_dyn.ref
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Studio with Modular Projects

R GAMS Studio
File Edit GAMS MIRO Tools View Help

EeR € @ e -

Project Explorer 8 X| wekome [  stg_tcyngms () sigtomistE) | stotdmrefE) | stgtdeteloadinc () stg_t:
v o8 stg_tdyn Al Symbols (742) |Fiter .
30.5_Calib Set (137) Fie Loca

= s 0| ET— Reference file option

= stg tdymgde Variable (137) Dyn GGEWod 016Woo
% sto_t_dyn.gms Parameter (365) | C:\Users\scott\OneDr 022-23) Dyn CGEWMod O16\Woe
3 sto_taynist Equation (101) | C:s tt\OneD: Dyn CGEWod O16Woc

stg_t dyn.ref | Model iy \ ive Dyn CGEWMod O16\Moc
File (0) C:\Users\scott\OneDr 3\ Dyn CGEVMod O16\WMoc

Functon (1) | G5\ gemod 2 22 Reqursive Dyn CGEWod 016Woc

Unused (57) | GV \ Dyn CGEMod O16Woc

Fleused () | CV5 tt\OneDrive \cgemod 022- Dyn CGEMod 016Moc

Process Log option
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Studio with Modular Projects

4 GAMS Studio
Fle Edit GAMS MRO Tools View Help

E=0 € om k- -
Project Explorer @ % g t listinc stg_t _parmcalib.inc stg_t_resassign.ir
v @ stgtdyn 1 ¥ o B

h 30_Cs_calib
Bm sto_t_dataloadinc
Bu sto_t alibchking
Bm sto_t_cap_valinc

Bu sto_t_conventing

stg_t_deseripiinc

stq_t_diagnost.ine

Bw sto_t listine £R.10 [
B stg_t_parmealib.inc CADWOR.LO - i
Ba sto_t resassigninc

B sto_t_samchkinc PWM. 1O (c) = i
mm st t_samchklinc PWE.LO (c) = -i

B sto_t samchk2in
B sto_t_structine
B sto_tvarinitinc
B sto_tvarinit2inc
v = 31.Cs Close
B stotd baseinc
B sta_t_c_tuin
B statd_tyhine
u sto_t resetinc
stg_t_dyn.gdx
 sta_t_dyn.gms
stg_t_dyn.ist

stg_t_dyn.ref

OEDADJ.LO =
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Studio with Modular Projects

nchkLinc stg_t_samchk2.inc stg_t_structinc stg_t_vannit‘mc@ 4;} | = | Process Log

~ Filename Line

w._dyn/30_CS_Calib/stg_t varinitinc 95 ADFD.L[ff,a] = ADFDO[ff,
«._dyn/30_C5_Calib/stg_t_varinit.inc 97 FD.L(ff,a) = FDO(ff,a);
t_dyn/31_C5_Close/stg_t_cl_twinc 208 ADFD.FX(ff.a) = ADFDO

Search Term: | FDO v ‘ Clear

‘ «.dyn/31_C5_Close/stg_t ¢l_baseinc 210  ADFD.FX[ff,.a] = ADFD{

Replace ..ta_t_dyn/30_CS_calib/stg_t_listinc 139 ADFDO[Ff,a) Shift paran
Case Sensitivity [ | Use Regex [ ] Whole Words Replace Al ..tg_t_dyn/30_CS_Calib/stg_t_listinc 169 FDO(ff,a) Demand for
wt_dyn/31_CS_Close/stg_t ol _tyhinc 208  ADFD.FX(ff,a] = ADFD{
..ta_t_dyn/stg_t_dyn/stg_t_dyn.gms 1211 FDPRODFN(ff a)S[FDO[T
468 FMEQUILIFSSUM(a, FDOA
iyn/30_CS_Calib/stg_t_varinitZ.inc 88 ADFD.L(ff,a] = ADFDO[ff,

Replace: |

This Project ~ < >

Include Filter: ‘ =

g_t_dyn/stg_t_dyn/stg_t_dyn.gms

Exdude Filter: ‘
..dyn/30_CS_Calib/stg_t_varinit2inc 90 FD.L(ff,a) = FDO[ffa);
| 40 matches; 20 files searched. | .N/30_C5_Calib/stg_t_data_lead.inc 313 *Fercing FSI0 and FDO b
..n/30_C5_Calib/stg_t_parmcalibiinc 334 FDO[ff,a) Demand for
More GAMS & Studio, 2025 © cgemod 24
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Studio with Modular Projects
nchkLinc stg_t_samchk2.inc stg_t_struct.inc stg_t_varinitinc £ |4:» | = | Processlog
~ Filename Line Conts
= x «.._dyn/30_CS_Calib/stg_t_varinitinc 95  ADFD.L{Ff,3) = ADFDO(f,a):
«._dyn/30_CS_Calib/stg_t_varinit.inc 97 FD.Liff,a) = FDO(ff.a);
Search Term: |FDIJ V‘ Clear ..dates/stg_t_cap_update_3_solinc 112  ..ikp,a), WFO(kp)*WFDISTO(kp,a)*FT
tg_t_dyn/30_CS_Calib/stg_t_listinc 139  ADFDO(ff,a) Shift parameter for fz
Replace: | || Replace
..to_t_dyn/30_C5_Calib/stg_t_listinc 169 FDO(ff,a} Demand for factor f by
Case Sensitivity [ | UseRegex [ ] Whole Words Replace Al ..._DYN_Close/stg t_dyn_cl_putty.inc 196  FD.FX(ka) = FDO[k,a)
Folder - < > w_DYN_Close/stg_t_dyn_cl_putty.inc 217 ADFD.FX(ff.a) = ADFDO[ff.a);
..1_DYN_Close/stg_t_dyn_cl_clay.inc 217  ADFD.FX[ff,a] = ADFDO(ff,a);
Indude Filter: \ = V| ..n/30_C5_Calib/stg_t_parmealibinc 334 FDO(ff.a) Demand for factor f by
Exdude Filter: ‘ "l ..N/30_CS_Calib/stg_t_parmcalib.inc 354  ADFDO(ff,a) Shift parameter for fa
«N/30_CS_Calib/stg_t_parmcalibinc 439  FDO(f.a) = FACTUSE(f.a);
Path: |l-7_2 Recursive Dyn CGE/Mod O 16/Mod 016 code/sto_t_dyn/stg_t_dyn Browse ..nf30_CS_Calib/stg_t_parmealibinc 447  FSIO{ent’,f) = SUM(a, FDO(f,a)) - (SL
Indude Subdirectaries ...n/30_CS_Calib/stg_t_parmealib.ine 451 Ensure F3I0 and FDO are consisten
...n/30_CS_Calib/stg_t_parmcalibinc 458  FDTOTO(f) = SUM(a, FDOIT,a) ;
‘ 57 matches; 84 fles searched. | \N/30_CS_Calib/stg_t_parmealibine 474 FSOf) = SUM[3,FDOM,al];
...n/30 CS Calib/stg t parmealibinc 503 WFDISTOIf.31SFDOIF.a) = (SAMI(f.al/F
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