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s Projects and Directories

§a GAMS Studic
File Edit GAMS MIRO Tools View Help

 Open Studio and make sure  |sag e om -
no projects are listed inthe  |7roe 7% emt et

Project Explorer o o
- - B procsel.gdx Column Listing
* Select File>Open in a New el N
Project (or Ctrl+Shift+O) ~ [-+r= e i
* Open the file transport.gms =
from the workspace directory | =™ e ETT777
« Select Open in a New Project e
« Open the file chenery.gms oty
from the workspace directory
» Select Ope_n In a New Project Many projects can
* Ppe” tthhe fllekprocseldgmst be called from within
rom the workspace directory —, ;o6 directorsl!
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Help with GAMS and GAMS Studio

Select: Help > GAMS Documentation,Or F1,0rView > Help

i ! GAMS Studio

10 390807 0 98 Yechiucal docuamentation heve  also 8 tulonal about he usage of GALES SHud:

Motivation

Central Widgets
Welcome Page

S 530,11 5 desgned 1o gie Quick acCess 0 Comman actons and %o ofer

comesponany th

o vaen
Getting Started Further Help v
— D
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Help with GAMS and GAMS Studio
Keyboard Shortcuts
L L I I )
2. Advanced Text Manipulation
Action Shortcut macO0Ss Description
Remove Line | Shift - Del Removes the current line
Duplicate Line | Ctrl- D Command - D Duplicates the current line
Lowercase | Alt- Shift-L | Option - Shift-L | Toggle selection to lower case
Uppercase | Alt- Shift - U | Option - Shift-U | Toggle selection to upper case
Tab Tab Tab Add spaces till next tab size
Untab Shift- Tab | Shift - Tab Remove spaces till previous tab size
Indent Ctrl-1 Command - | Indent complete line
Qutdent Ctrl - Shift -1 | Command - Shift- | | Outdent complete line
Find Ctrl-F Command - F Open Search & Replace window, filling search field with selected text if there is any.
Find Next F3 F3 Jump to next search result if
Find Previous | Shift - F3 Shift - F3 Jump to previous search result
3. Navigation & Selection
1l Action Shortcut macOS$S Description
Zoom In Ctrl - + or Command - + or Zoom in
Ctrl-=or Command - = or
Ctrl - Wheel Up Command - Wheel Up
Zoom Out ctrl- -or Command - - or Zoom out
Ctrl - Wheel Down Command - Wheel Down
Reset Zoom Ctrl- 0 Command - 0 Reset zoom
Match Parentheses Ctrl-B Command - B Jump to matching parenthesis
A
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Search & Replace
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Search and Replace

Parameter c(i,j) 'transport in thousands of dollars per case';

c(i,j) = £*d(i,j)/1000;
varial?le_ . ma Search & Replace X
%(i,7) 'shipment gqu
z "total transl Search Term: |cnst v| Clear
Replace: | | Replace
Positive Variable x; Case Sensitivity || Use Regex Whole Words Replace Al
E@ation This File ~ = Find Al
'define o | |
R 4 matches,
supply (1) 'observe
demand (j) 'satisfy demand at market j';:
.. z =e= sum((i,3), c(i,J)*=(i,3)):
supplv(i) .. sum(i, =(i,7)) =1= a(i):
More GAMS & Studio, 2022 © cgemod g "
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= Process Log
~ Filename Line
rsfseott/D i rt.gms 4 This problem finds a least
2u Search & Replace X
rs/scott/D rt.oms 42 Parameter ¢lij) ‘transport
_ | search Term: ‘mst v‘ Clear tt/D 5, rt. 47 .. 'total co:
- ‘ ‘ tt/D if rt. 52 cost  ‘define objective f
3 R
Replace: eplace rs/scott/D rtoms 56 cost. z=e=sumi(ij) o
Case Sensitivity [ ] UseRegex [ ] Whole Words Replace All 1 D Ist 7 ...This problem finds a lea
3L D Ist 44 «.Parameter cfi,j) ‘transpo!
This Project v < Find All i) P
i cn Dot Ist 49 ..total o
Include Filter: | v‘ cn Doc Ist 54 52 cost define obje:
1 D 5/Studi v Ist 58 56 cost. z=e= sumffij
Exclude Filter: | ~]
[} Dol Ist 77 ---cost =E= define obje
. ‘ 20 matches; 4 fils searched. ‘ an Do 15t 79 cost. -D225°(seattieng
1 L D Ist 106 0,225 cost
4L D Ist 112 -0.153 cost
A Dol Ist 118 -0.162 cost
I (=11 Do Ist 124 ..z total transportatio
" D its/GAM! Ist 128 1 cost
cn Doct Ist 189 --EQU cost
u A Do Ist 191  cost define objective fun
. Y
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me GAMS Studic

Opening and Using GDX Files

File Edit GAMS WMIRO Tools View Help
Es=R €5 @l k- 0|
Project Explorer T X Welcome [

trnsport.gms [

trnspart.

Jst (£

trnsport.gdx [£J

v trnsport Filter: [ Al Columns
= tad
= tmspo Entry Mame Type Dim  Records Text
#p: tmsport.gms 3a Parameter 1 2 capacity of plant i in cases
E tmsport.Ist 4 b Parameter 1 3 demand at market j in cases
Tc Parameter 2 6 transport cost in thousands of dollars per...
10 cost Equation 0 1 define objective function
5d Parameter 2 6 distance in thousands of miles
12 demand Equation 1 3 satisfy demand at market |
6 f Parameter 0 1 freight in dollars per case per thousand ...
1]i Set 1 2 canning plants
2] Set 1 3 markets
11 supply Equation 1 2 observe supply limit at plant i
8 x Variable 2 & shipment quantities in cases
9z Variable 0 1 total transportation costs in thousands of...
. N
More GAMS & Studio, 2022 © cgemod 11
e GAMS Studic
File Edit GAMS MRO Tools View Help
=0 €5 9 b 0|
Project Explorer B X | Welcome []  tmsport.gms [[]  tmsportref[[] = chenery.gms [£]  procselgms [£]  procselist ]  tmspo
v 0 chenery Fiter .. TR M| | Table View
b chenery.gms Enty Neme  Type  Dm Records Text X1t %j: % vae
¥ %° procsel 3a Parameter 1 2 capacity of pant | | ceatte  new-york 0.225
£ procselgx ab Parameter 1 3 demand atmarke | |ceatie  chicago 0.153
a procseloms |7l paanet: B <o tooca 0.102
procsel.Ist 10 cost  Equation 0 1 define obectve || san diego new-york 0.225
v os tmsport 5d Parameter 2 6 distance in thous...| | can-diego chicago 0.162
tsport.gdx 12 demand Equation 1 3 satisfy demand a...| |san-dego topeka 0.126
&% tmsport.gms 6 f Parameter 0 1 freightin dolars
[ tmsportist 1i Set 1 2 canning plants
trnsport.ref 2j Set 1 3 markets
11 supply  Equation 1 2 observe supply li
8 x Varisble 2 6 shipment quantti
sz Variable 0 1 total transportati.
List View
= iz
| xi | % J | ® Value
new-york chicage topeka
seattle 2.25e-01 1.533e-01 1.62e-...
san-diego 2.25e-01 1.62e-01 1.26e-...
. N
More GAMS & Studio, 2022 © cgemod 12
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git | vahe
|F\Iter \‘—‘(l
new-york
chicago
topeka
Select All Invert Deselect Al ¥
[ Hide unselected items = Min: Max: —
0.126 | [0.225 |
It
7t |:| Exclude
Show Special Values:
+INF -INF
UNDF Acronyms
Reset
N Y
More GAMS & Studio, 2022 © cgemod 13
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Entry Neme Type Dim Records Text Xmh: w=: Wsde? |\,‘. |* Value
& aio Parameter 2 6 input coeffidents
lightind  food+agr heavyind  services
13 ap Parameter 1 3 slope of export revenue function ’
ow a dsv | 05 0o 26 08
57 di Parameter 0 1 cost of living index ~
effic 3.82 3.24 4 1.8
53 cva Parameter o 1 total value added at current prices
b distr 0.278 1034 26 0.77
23 dbar  Parameter o 1 trade defidt
effic 2.551 3.3 4 177
8 ddat  Parameter 3 20 demand parameters
medm s sbst  0a1 029 02 005
18 del  Parameter 1 4 distribution parameter in produiction functions
dsr 0.3 04 0591 0.0079%
44 dem  Equation 1 4 demand equations
effc 37 3m 167 1e4
42 dg Equation 1 3 definition of imports
bkt 022 0s 04 o0a
43 dh Equation 1 3 definition of exports
distr 0.41 0.47 0.92 0.08
51 dk Equation 1 4 definition of capital coefficient
effic 3.99 3.33 18 1.89
50 d Equation 1 4 definition of labor coeffident
high a subst 0.45 115 0.4 0.2
39 dty Equation o 1 total demand: definition
distr 0.456 0.483 0.817 0.23
52.dv  Equation 1 4 value added
effc 4 am B 1:
48 dw  Equation 1 4 definition of v
bowbst 093 1l 08 o0
Ne Variable 1 3 quantity of exports
dsr 084 0483 076 0.344
15 efy Parameter 1 4 effidency parameter in production functions
offc 4 am 196 1
56 emp  Parameter 0 1 total employment
48 for Equation o 1 factor price ratio definition
55 fve Parameter o 1 foreign exchange value of exports.
2g Variable 1 3 foreign exchange cost of imports
12 gam  Parameter 1 3 intercept on export revenue function
3 h Variable 1 3 foreign exchange value of exports
1i Set 1 4 sectors
513 Alias 1 0 Aliased with i
Bk Variable 1 4 capital use per unit of output
22 kbar  Parameter o 1 capital stock.
a6 ko Equation o 1 capital constraint
21 Variable 1 4 labor use per unit of eutput
20 bbar  Parameter 0 1 total supply of labor
45k Equation o 1 labor constraint
3 mh  Set 1 3 possible elastidities
31m Variable 1 3 quantity of imports.
40 mb Equation 1 4 material balance
10 mew  Parameter 1 3 intercept on import cost function
27 p Variable 1 4 prices I
36 pd  Varisble 1 price deflator
|| [ ooosonds ]
More GAMS & Studio, 2022 © cgemod 14
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Opening and Using GDX Files

ams £ trnsport.ref [ chenery.gms £ procsel.gms [£) procsel.Ist [ trnsport.gdx [ M
S50 | Table View
Dim  Records Text Wit Wiz % Level % Marginal % Lower % Upper % Scale

1 2 capadty of plant .| |geatle  new-york 50 ] 0 +INF 1
1 3 demand atmarke...| |seatfle | chicago 300 0 0 +INF 1
2 6 transport costin .| | zeatte topeka 0 0.036 0 +IMF 1
0 1 define objective ... | |san diego new-york 275 0 0 +HIMNF 1
2 6 distance in thous... san-diego chicago il 0.009 0 +IMF 1
1 3 satisfy demand a... san-diego topeka 275 a 0 +INF i
0 1 freightin dollars ...
1 2 canning plants
1 3 markets
1 2 observe supply ...

I-‘ pment quantiti...
[u} 1 total transportati...
More GAMS & Studio, 2022 © cgemod 15"
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Opening and Using GDX Files

trnsport.ref [ chenery.gms [£] procsel.gms [ procsel.lst [ trnsport.gdx (£ trnsport.lst [
SRS M| | Table view
ords Text ®it ®ij? ® Level % Marginal ® Lower ® Upper } Scale
2 capadity of plant ...| | seatte  new-york 50 0 0 +HINF 1
3 demand atmarke .| |ceatte  chicago 300 0 Q +INF 1
6 transport costin seattle  topeka 0 0.038 o +INF 1
1 define objective san-diego new-york 275 0 0 +HNF 1
& distance in thous... | |can-diega chicage 0 0,008 Q +INF 1
3 satisfy demand a...| | san-diego topeka 275 0 0 +HNF 1
1 freightin dollars
2 canning plants
3 markets
2 observe supply li
Preferences
| 6|shipment quantit i
1 total transportati... Level
Marginal
Lower Bound
Upper Bound
Scale
Invert Selection
. 5 ™
More GAMS & Studio, 2022 © cgemod 16
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Opening and Using GDX Files

0| List view

|$;<i1 |$;<j2 |§<LEVE|

new-york  chicago  topeka
Level Copy {comma-separated) Crl+C

Is...
o G o S
4| |san-diego - Copy Without Labels (comma-separated)

j Copy Without Labels (tab-separated)

P Auto Resize Columns Ctrl+R
Select Al Cirl+a

nti

More GAMS & Studio, 2022 © cgemod 17

17

Reference Files
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Reference Files

liew  Help
~ [ rfdefault
P X | welcome [ trnsport.gms [ trnsport.Ist [

b=~ [~ [rfdefautt
Welcome [ trnsport.gms [ trnsport.ref [ trnsport.gdx [ chenery.ams [£] chenery.lst [ chenery.adx [ trnsport.Ist [£]
All Symbols (13)  [Fiter ... 255 00| [ Location line  Column
set (2) | ~ (1) Dedared in
Entry MName Type Dim Domain Text s 12
Acronym (0) 139 a Parameter 10 capadity of plant i in cases (0) Defined
Variable (2) 140 b Parameter 10 demand at market j in cases ~ (1) Assigned in
trnsport.gms 43 11
Parameter (5] 3
& |26 | (©) Impictly Assgned
Equation (3) 146 cost Equation 1] define objective function (0) Contralled
Maodel (1) 141 d Parameter 2 i) distance in thousands of miles ~ (1) Referenced in

More GAMS & Studio, 2022 © cgemod 19 R
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welcome ] gb_cc_s.gms ] gb.cc skt ghcc SrefE gamsconfia.yaml (£
all Symbols (268) | iter: [ a1 Coumns
Set (172) Entry Name Dim Domain Text “ || Location Line Co
Acronym (0) 147 a 1 (sac) activity accounts ~ (1) Declared in
Variable (142) 182 a_h 1 (sac) Activities and households glb_CC_5.gms 2583
Parameter (418) 156 a_k_fx 1 (a) Activities with fixd capital ~ (1) Defined in i
Equation (115) 155 aagg 1 (aagg) Aggregate activity groups glb_CC_data Joadinc 89 10
(0) Assigned
Model (1) 148 aagr 1 (@) Agricultural activities (0) Implicitly Assigned
File (10) 152 acns 1@ Censtruction activities (549) Controlled in
Function (1) 225 acx 2 (a0 activities purchased domestically (1610) Referenced in
Unused (59) 226 acxn 2 (an) activities NOT purchased domestically
File Used (10) 150 afd 1 (a) Food activities
151 aind 1@ Industrial activities
193 aleon 1 (3) activities with Leontief top level prodn function
149 anat 1 (@) Natural rescurce activities
241 ap 1 Aliased with a
191 aqgx 2 (arn) Activities and regions with CES fn at Level 1
192 agxn 2 (ar) Activities and regions with Leontief fn at Level 1
154 aser 1 (a) Service activities
133 auti 1@ Utility activities
144 cagg 1 (cagg) Set of commaodity groups for reports
Y
More GAMS & Studio, 2022 © cgemod 20
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Configuring Studio
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06 - - -
Configuring Studio

B Settings X

General  Fditor &log ~ GDXViewer  Colors  Remote  Misc.

e —_Understanding the

welcome page 5 T
Open file options
before running g GAMS
Open .Ist file after running GAMS (@ Open file in current project by default
Jump to first compilation error () Open file finds or creates new project

Raise GAMS Studio when opening a flle

e Ctrl+O
VvV
Ctri+Shift+O

oK Cancel Apply

More GAMS & Studio, 2022 © cgemod 2
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ols  View Help
'“g 4 = | rf=default cerr=5 gdx=default s=save]
Welcome trnsport.ams [ trnsport.ref trr
I
- -
Welcome trnsport.gms gamsconfig.yaml [E] trnsport.ref trnsport.gdx chenery.gms chenery.lst chenery.gdx
Filter Parameters ...
Key Value minVersion  maxVersion Parameter Synenym Defialue Range Type
Action A CE 1R, C,E,..,GT} Enumé
W Reference Default AppendExpand AE 1 {0,1} EnumI
W cEr 10 AppendLog AL 0 {01} Enuml
AppendOut AD 0 {01} Enuml
AsyncSollst 0 {0,1} EnumI
. Y\
More GAMS & Studio, 2022 © cgemod 23
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User Model Libraries

24
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B Libraries and User Model Libraries

User Model Libraries are libraries additional to those
provided by GAMS

* In Windows Explorer create a directory, C: \cgemod training.
We suggest doing this on the top level of you working drive (C drive).

* Add the sub directory cgemod 1ib to the master directory, i.e.,
C: \cgemod_training\cggmod_l ib. (Each course adds more
files and the index will be updated.

* Add the sub directory downloads to the master directory, i.e.,
C:\cgemod training\downloads.

» Download the trans.zip file from the cgemod site
(http://cgemod.org.uk/int gams.html) (save in the
download sub directory).

* Unzip the contents of the file trans.zip into the sub directory
called cgemod 1lib.

More GAMS & Studio, 2022 © cgemod 25
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B ibraries and User Model Libraries v1

Making the User Library available in Model Library Explorer

“ < Open Studio settings - File >
Settings or F7 andgo tothe
Misc tab.

» Change the path for the User Model
library,
C:/Users/../Documents/GAMS/
modellibs (the exact path will
depend on the settings on your PC) to
C:/cgemod training/cgemod
lib.

 Close down the Studio Settings
window remembering to click OK at
the bottom of the Mi sc tab.

=0 >

More GAMS & Studio, 2022 © cgemod 26‘
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ibraries and User Model Libraries v2
Making the User Library available in Model Library Explorer

» Copy all of the files in the cgemod 1ib sub
directory — just the contents of the directory NOT

the directory.
+ Open Studio settings - File > Settings
et Gl Qe Gl R or F7 on the toolbar and go to the Mi sc tab.
o e * Click on the ‘Open Location’button (—),
which will open a Windows Explorer window.
Co e o Ll Make sure the directory ..\GAMS\modellibs
oo et e is open.
e e  Create a sub directory called

..\GAMS\modellibs\cgemod lib
* Then Paste the contents of the

“iher dmetng or repacng an ot

o el o, TP S C:\cgemod training\cgemod 1lib
directory into'the
..\GAMS\modellibs\cgemod lib
directory.

* Close down the Studio Settings window
remembering to click OK on the Misc tab.

More GAMS & Studio, 2022 © cgemod 27
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Libraries and User Model Libraries

s

an Model Library Explorer

Filter model tabs ...

3 Intro to Studio Lib (5)  Model Library (430)  TestLibrary (895)  APILbrary (1)  Data Utilities Library (145) E

:‘ SeqMr  Name Model Type Type Modeling Points
_; o0 transport]l Transport cost problem LP Structure of GAMS model  None
| oz Syntax Syntax errors 1to 4 LP Debugging a GAMS model None

03 Execution Execution errors 1and 2 LP Debugging a GAMS model Mone
2 transport2 Transport model exercises  LP Madifying a GAMS moedel  Adding markets and wholesalers
05 transport3 Transport exercise solutions LP Madifying a GAMS moedel  Adding markets and wholesalers

More GAMS & Studio, 2022 © cgemod 28
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3 > cgemod_training >
A Name

cgemed_lib

downloads

Libraries and User Model Libraries

Date modified

Trpe Size

File folder

File folder

View
Sort by
Group by
Refresh

Customise this folder.

> Using File>New Project
to create a new directory
AND a new project

Paste
Paste shortcut
Undo Delete Ctrl+Z
Giveaccessto >
&) SYN Cheekout..
45 TortoiseSYN >
&] WinMerge
New > Folder
Properties | Shortcut
[ Microsoft Access Database
| » cgemod_training »
~
~ Name Date medified Type
cgemad_lib File folder
downloads Filfolder
125
transport ‘Fv\e folder
More GAMS & Studio, 2022 © cgemod 29
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Libraries and User Model Libraries

File Edit GAMS MIRO Tools View Help
=0 €~ oM ML
Project Explorer 2 X | welcome [ [transport] £
¢ transport
MName |transport

Working directory |C:\GAMwaa\n\ng\transport
Base directory

Main GMS

File Edit GAMS
=D ¢
Proect Exgrer

% wansport

|C:\GAMS_Ha\n\ng\transDurt

king directol

Took View Help

-no runnable-

[t o

Sl N
B x| wexome [ramsport) @
Hame varmport
Workng drctary [C:\6aMS_vanngirarport
Sasedreciory [CH1GAMS_ranng rarsport
Main @S .

5 ModelLibrary Exploser

x

& tnirs o Sucdo L (%)

Seqhir

o
@
]
o
s

More GAMS & Studio, 2022

ModelLbvary (4)  Testibray (395)  APILbrary (51 Data Utibes Livary (145)
Neme Model Type Tpe  Modeling Faints
transport] Transport costproblen 1P Structure of GAMS model  None
Symtax Syniam emors 1104 LP  Debugging 2 GAMS model None
Execution Execubionermers 1and2  LP  Debugging 8 GAMS medel None
tanspon2 Transpert model ecercises LP Modifying 2 GAMS model  Adding markets and wholesalers

tranzport3 Trarapert exercise soluticns LP

Modifying s GAMS model Adding markets snd whelezsiers

© cgemod

oA Lbeary (4
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Libraries and User Model Libraries

§a GAMS Studio
File Edit GAMS MRO Tools View Help

R=0 € o k- -]

Project Explorer 8 X welome [[]  [transport] [ trans.gms (B
¥ %* transport 1 BTITLE A TRANSPORTATION PROBLEM (TRNSPORT,SEQ=1)

ap: trans.gms SOFFUPPER

cgemod_training * transport

~ MName Date modified Type
[ clean_tr.dat DAT File
A trans.gms GAMS file
|J trans.gms.1.bak BAK File
@transexcel.xls Microsoft Excel 97...
@tutorial.pdf Microsoft Edge P...
More GAMS & Studio, 2022 © cgemod 3
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Comparing Files

Access to comparison software is valuable. They allow easy

comparisons between different model versions, which can be

helpful when searching for ‘changes’, ‘errors’ and ‘bugs’.

1. MS Word: using Review>Compare produces a comparison

of two selected documents

2. WinMerge: using File>Open than then selecting 2 or 3
documents to compare

3. NotePad++: open two documents and then using
Plugins>Compare

The courses offered by cgemod assume the participant has access

to comparison software. Our examples assume WinMerge.

With open-source programmes be careful when installing
them, especially if they come from third-party sites.

More GAMS & Studio, 2022 © cgemod 33
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Studio with Modular Projects
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Studio with Modular Projects
Name - Status Date modified Type
10_CS_Data [ 1) 31/08/2022 11:02 File folder
11_DYM_Data @A 31/08 File folder
20_GDX_Data [ 1) 31/08/ File folder
21_Restart [} 31/08 File folder
30_CS_Calib (- o) 31/08/ File folder
31_CS Close [ 1) 31/08/ File folder
32_C5_Expts [} 31708/, File folder
40_DYN_Calib (- o) 31/08/ File folder
A1_DYM_Close [ 1) File folder
42_DYMN_Updates [} File folder
43_DYMN_Expts [ 1) File folder
50_C5_Analysis [ 1) File folder
51_DYM_Analysis @A File folder
60_Results [ 1) 31/08/ File folder
clean_stg_t.bat [ 1) 13/03/2020 0%:41 Windows Batch File
au stg_t.gms @a 10/03; GAMS file
au stg_t_dyn.gms [ 1) 04/10/ 7 GAMS file
AW stg_t_dyn_expt.gms [ 1) 13/03/2020 0%:41 GAMS file
More GAMS & Studio, 2022 © cgemod 35‘ X
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Studio with Modular Projects
[
File Edit GAMS MIRO Teols View Help
=0 ¢ -3 R M
Project Explorer B X| welcome ] sty tdyngms B stg_tdynistE]  stg_t dynref £
V% stg_tdyn 439 2 N tr
= stg t dyn.gdx Sofftext
ap: stg_t dyn.gms
[®) stat dynst 442  SINCLUDE 30 CS Calib\stg t data load.inc
stg_t_dyn.ref ::_
am GAMS Studio
File Edit GAMS MIRO  Tools View Help
k=0 ¢ S| = 0
Project Explorer B X | welcome [[]  stg_tdyngms ]  stg_t dataloadinc @ stg_te
v 8¢ stg_t dyn 1 1o
A 30_C5_Calib
m sto_t_data_load.inc
g stg_t_dyn.gdx
ap: sto_t dyn.gms
@ stg_t_dyn.lst .
stg_t_dyn.ref o
More GAMS & Studio, 2022 © cgemod 36‘ %
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g GAMS Studio

Studio with Modular Projects

Reference file option

File Edit GAMS MIRO Tools View Help
=0 ¢ om0~
Project Explorer B X | wecome £)  stotdynoms E] st tdynist[d  stgtdmnrefE  stotdataloadinc ] stots
sto_tayn Al Symbols (742) [Fier .
30.¢5_Calib Set(137) File Loca
31.65_Close Acronym (0) \scott\OneDrive \cgemod courseslegemod 2022 1-22 Recursive Dyn CGEWod 016WMo
stg_t_dyn.gdx Variable (137) ), Dyn CGEMod 0 16\Moc.
B sto_tayn.gms parameter (365) | C: \OneDrive\cgemod 202223\20: Dyn CGEWod 016 WMo
@) stotdymist Equation (101) 2 gemod \ Dyn CGEWMod 016WMoc
stg_t_dyn.ref Model (1) c 2022-23\20: Dyn CGEMod O 16\Moc
Fi () c \oneDrive cgemod Dyn CGEWod 016 WMo
Function (1) | Dyn C6E\od 0 16\Woc
Unused (57) c \OneDrive \cgemod 2022-23\20: Dyn CGE\Mod O 16\Moc
Fie Used (9) gemod Dyn GGEWod 016Woc
tt\OneD Jom:
More GAMS & Studio, 2022 © cgemod
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Studio with Modular Projects

GAMS Studio
File Edit GAMS MRC Tools View Help
E=0 € s@ k- -
Project Explorer & X 4 thistinc[)  stg_tpamcalibinc 0]  stg_t_resassign.ir
v @ stg_tdyn 1

~ I 30.C5 Calib

Bu stg_t_data load.ine
W sto_t calibchkiinc
m 5tg_t_cap_valinc
m stg_t_conventinc

w sto_t_descrip.inc

m sto_t_diagnostine

stg_t_samchkZ.inc

Ba stg_tvarinitine

u sto_t d baseinc

Bu sto_t resetinc
= stg_t.dyn.gdx

i stot.dynams
3 stg_taynust
stg_t dyn.ref

More GAMS & Studio, 2022
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ER.LO -i

mm sto_t_parmealib.ine CAPWOR.LO -1
Ba sto_tresassign.inc

stg_t_samchk.inc PWM.LO(c) -i

stg_t_samenkine PWE.LO (c) -i

SADJ.LO
Bu sto_tvarinit2ine

SHADJ.LO =
31.CS5_Close “Eaby IO :

LAY
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nchkl.inc stg_t_samchk2.inc stg_t_struct.inc

stg_t_varinit.inc ] | 4:» | = | ProcessLog

Search Term: | FDO

~ Filename Line
% w._dyn/30_CS_Calib/stg_t_varinit.inc 95 ADFD.L(ff,a] = ADFDO(ff,
«.._dyn/30_C5_Calib/stg_t_varinit.inc 97 FD.L(ff,a) = FDO(ff,a);
v‘ Clear w_t_dyn/31_C5_Close/stg_t_cl_twinc 208  ADFD.FXiff,a) = ADFDO

Replace: |

«dyn/31_C5_Close/stg_ t o _baseinc 210 ADFD.FX[ff,a) = ADFD(
‘ Replace

Case Sensitivity [ | Use Regex [ ] Whole Words

This Project ~ <

..tg_t_dyn/30_CS_Calib/stg_t_listine 139  ADFDO(ff,a) Shift paran
Replace Al wto_t_dyn/30_CS_Calib/stg_t_listinc 169  FDO[ff,a) Demand for
wt_dyn/31_CS_Close/stg_t_cl_tyhinc 208  ADFD.FX(ff,a) = ADFD{
..tg_t_dyn/stg_t_dyn/stg_t_dyn.gms 1211 FDPRODFNIf,a)S{FDO(fT,:

Include Filter: ‘ =

wto_t_dyn/stg_t_dyn/stg_t_dyn.gms 1468 FMEQUIL(fISSUMI(a, FDO{

Excude Filter: ‘

..dyn/30_C5_Calib/stg_t varinitZinc 88 ADFD.L[ff,a] = ADFDO(ff,

| 40 matches; 20 files searched

iyn/30_C5_Calib/stg_t_varinit2.inc 90 FD.L(ff,a) = FDO(ff,a);
/30_C5_Calib/stg_t_data_load.inc 313 * Forcing FSI0and FDO ©

.n/30_C5_Calib/stg_t parmcalib.inc 334 FDO[ff,a) Demand for

More GAMS & Studio, 2022 © cgemod 39 "
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nchk.inc sto_t_samchk2.inc sta_t_struct.inc stg_t_varinitinc () |4:» | = | Processlog
~ Filename Line Conts
: x dyn/30_CS_Calib/stg_t_varinitinc 95  ADFD.L(ff,a} = ADFDO(,3);

dyn/30_C5_Calib/stg_t varinitine 97  FD.L{ff,a) = FDO[ff,a};

Search Term: | FDO

V‘ Clear ates/stg_t_cap_update_3_solinc 112 ..(kp,a), WFO{kp)*WFDISTO(kp,a}*FC

Replace: |

wtg_t_dyn/30_CS_Calib/stg_t_list.inc 139 ADFDO(ff,a] Shift parameter for fi
|| Replace

Case Sensitivity [ ] UseRegex [ ] Whole Words

Folder ~ <

.. tg_t_dyn/30_CS_Calib/stg_t_listinc 163  FDO[ff,a) Demand for factor f by
Replace Al .._DYN_Close/stg t dyn_d_puttyinc 196  FD.FX{ka) = FDO[k,3);

= «._DYN_Close/stg_t_dyn_cl_putty.inc 217  ADFD.FX(ff.a) = ADFDOIff.a);
]

..1_DVN_Close/stg_t_dyn_dl_clayinc 217 ADFD.F¥(ff,a) = ADFDO(ff,a

Include Filter: [ *

/30_CS_Calib/stg_t_parmealib.inc 334  FDO(ff.a) Demand for factor f by
Exclude Fiter: ‘ "l ..N/30_CS_Calib/stg t parmcalib.inc 354  ADFDO[ff,a] Shift parameter for fa
..N/30_CS_Calib/stg_t_parmcalib.inc 439  FDO(f.a) = FACTUSE(f,a);
Path: |L—22 Recursive Dyn CGE/Mod O 16/Mod O16 code/stg_t_dyn/stg_t_dyn Browse ..n/30_CS_Calib/stg_t_parmcalib.inc 447  FSIO[ent' f) = SUM(a, FDOIf,a}) - (SL
Indude Subdirectories ...n/30_C5_Calib/stg_t_parmealib.inc 451 Ensure F5I0 and FDO are consisten
..N/30_CS_Calib/stg_t parmealib.inc 458  FDTOTO(f) = SUM(a, FDO(f.a));
| 57 matches; 84 files searched. | \N/30_CS_Calib/stg_t_parmealibine 474 50 = SUM[a,FDO,a]];
...n/30 CS Calib/stg t parmealibinc 503 WFDISTOIf.318FDOIF.a) = (SAM(f.al/F
. kS
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The End
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